古力娜扎身高体重图片:指标源码:“唉呀跳空”等指标5合1信号集(副图)2

来源:百度文库 编辑:八卦区 时间:2020/01/25 08:18:51
TD2

{TD DEMARKERⅡ等指标5合1信号集,50.00;60.00;68.00;78.88}

{买压卖压(TD DEMARKERⅡ),汤姆.迪马克}
FZ:=MAX(HIGH-REF(CLOSE,1),0)+(CLOSE-LOW);
FM:=MAX(REF(CLOSE,1)-LOW,0)+(HIGH-CLOSE);
TD8:100*SUM(FZ,8)/SUM(FM+FZ,8),COLOR9900FF,LINETHICK2;
B1:IF(COUNT(TD8>60,3)=3,72,40),COLORFF00FF;
B2:IF(COUNT(TD8>60,6)=6,69,40),COLOR33CCFF;
警:IF(COUNT(TD8<40,7)=7,66,40),COLORBLUE;


{“唉呀跳空”交易系统,拉瑞.威廉姆斯
拉瑞.威廉姆斯在其著作《短线交易秘诀》中称,该系统是其研究过以及交易过的最值得信赖的短线形态,许多系统开发人员都把它纳入实务操作当中。从某种意义上来说,这是一个心理交易系统,主要是量度过度的情绪化反应,导致的价格突变。其基本走势是在一个下跌趋势中,价格在箱形区间的下档附近波动持续5到10天,然后大幅低开跌破趋势线,卖压情绪极度高涨,如果随后反弹到昨日的最低价时,表明市场能量反转、另一波凌厉的涨势蓄势待发。

    系统买入机械规则
    ⒈ 收盘价比五日均价低4%,确保信号发生在跌势;
    ⒉ 开盘价低于昨日最低价1%;
    ⒊ 收盘反弹至昨日最低价以上。}

W1:=CLOSE<0.96*MA(CLOSE,5);
W2:=OPEN<0.99*REF(LOW,1);
W3:=CLOSE>REF(LOW,1);
B0:IF(W1 AND W2 AND W3,75,40),COLORRED;


{RSI三重平滑线,康斯坦丝.布朗简}
LC := REF(CLOSE,1);
RSI14:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
YSZD:=MA(MA(RSI14,5),3)-MA(MA(MA(RSI14,5),3),9);
KB:=YSZD>REF(YSZD,1) AND REF(YSZD,1)=REF(LLV(YSZD,100),1);
B:IF(KB=1,75,40),COLORWHITE;


{2B法则,维克多.斯波朗迪}
V1:=REF(LLV(CLOSE,100),10);
V2:=LLV(CLOSE,100);
V3:=CLOSE>V1 AND V20.95*V1;{验证回升,验证已适度创新低}
警2:IF(V3=1,63,40),COLORGRAY;


{价量摆荡法则——马丁.普林格}
BD:=(CLOSE/MA(CLOSE,28)-1)*100;
警3:IF(BD<-10,60,40),COLORGREEN;

{通达信虚拟成交量周、3日、日、120分钟、60、30、15分钟}
VV1:=IF(CLOSE<150,100*VOL/(FINANCE(7)/100),IF(PERIOD=8,VOL/10000,AMOUNT/100000000));
VV0:=IF(FROMOPEN>120,FROMOPEN-120,FROMOPEN);
VV2:=IF(FROMOPEN<=60,FROMOPEN,IF(FROMOPEN<=120,FROMOPEN-60,IF(FROMOPEN<=180,FROMOPEN-120,IF(FROMOPEN<=240,FROMOPEN-180,FROMOPEN))));
VV3:=IF(FROMOPEN<=30,FROMOPEN,IF(FROMOPEN<=60,FROMOPEN-30,IF(FROMOPEN<=90,FROMOPEN-60,IF(FROMOPEN<=120,FROMOPEN-90,IF(FROMOPEN<=150,FROMOPEN-120,IF(FROMOPEN<=180,FROMOPEN-150,IF(FROMOPEN<=210,FROMOPEN-180,IF(FROMOPEN<=240,FROMOPEN-210,FROMOPEN))))))));
VV4:=IF(FROMOPEN<=15,FROMOPEN,IF(FROMOPEN<=30,FROMOPEN-15,IF(FROMOPEN<=45,FROMOPEN-30,IF(FROMOPEN<=60,FROMOPEN-45,IF(FROMOPEN<=75,FROMOPEN-60,IF(FROMOPEN<=90,FROMOPEN-75,IF(FROMOPEN<=105,FROMOPEN-90,IF(FROMOPEN<=120,FROMOPEN-105,IF(FROMOPEN<=135,FROMOPEN-120,IF(FROMOPEN<=150,FROMOPEN-135,IF(FROMOPEN<=165,FROMOPEN-150,IF(FROMOPEN<=180,FROMOPEN-165,IF(FROMOPEN<=195,FROMOPEN-180,IF(FROMOPEN<=210,FROMOPEN-195,IF(FROMOPEN<=225,FROMOPEN-210,IF(FROMOPEN<=240,FROMOPEN-225,FROMOPEN))))))))))))))));
VV6:=IF(CURRBARSCOUNT=1,IF(PERIOD=5,VV1*240/FROMOPEN,IF(PERIOD=8,VV1*120/VV0,IF(PERIOD=4,VV1*60/VV2,IF(PERIOD=3,VV1*30/VV3,IF(PERIOD=2,VV1*15/VV4,VV1))))),VV1);
VV:=IF(PERIOD=6,IF(WEEKDAY=1,5*VV6,IF(WEEKDAY=2,5*VV1/2,IF(WEEKDAY=3,5*VV1/3,IF(WEEKDAY=4,5*VV1/4,VV1)))),IF(PERIOD<=5 OR PERIOD=8,VV6,VV1)),COLORRED,LINETHICK1;

BDV:=(VV/MA(VV,28)-1)*100;
警4:IF(BDV<-50,57,40),COLORGREEN;



{小结
    以上交易系统,均为当今世界一流顶尖操盘手或分析师的代表作品,当然是在他们公诸媒体的范围内说的。可以看出,除“唉呀跳空”交易系统外,其余系统并不具备稳定获利的能力。我们之所以把它们拿来探讨,更重要的是了解机械操盘系统的构思、创建方法,真正有效的机械操盘系统必须是由自己领悟出来、并付诸实战检验后的,这一点恐怕很难走出什么捷径来。};



=========

RSI3

{RSI3等指标5合1信号集,0.00}

{RSI三重平滑线,康斯坦丝.布朗简}
LC := REF(CLOSE,1);
RSI14:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
YSZD:MA(MA(RSI14,5),3)-MA(MA(MA(RSI14,5),3),9),COLORSTICK;
B:10*(YSZD>REF(YSZD,1) AND REF(YSZD,1)=REF(LLV(YSZD,100),1));


{“唉呀跳空”交易系统,拉瑞.威廉姆斯}
W1:=CLOSE<0.96*MA(CLOSE,5);
W2:=OPEN<0.99*REF(LOW,1);
W3:=CLOSE>REF(LOW,1);
B0:IF(W1 AND W2 AND W3,10.5,0),COLORRED;


{TD DEMARKERⅡ,汤姆.迪马克}
FZ:=MAX(HIGH-REF(CLOSE,1),0)+(CLOSE-LOW);
FM:=MAX(REF(CLOSE,1)-LOW,0)+(HIGH-CLOSE);
TD8:=100*SUM(FZ,8)/SUM(FM+FZ,8),COLOR9900FF,LINETHICK2;
B1:IF(COUNT(TD8>60,3)=3,9.5,0),COLORFF00FF;
B2:IF(COUNT(TD8>60,6)=6,9,0),COLOR33CCFF;
警:IF(COUNT(TD8<40,7)=7,8.5,0),COLORBLUE;


{2B法则,维克多.斯波朗迪}
V1:=REF(LLV(CLOSE,100),10);
V2:=LLV(CLOSE,100);
V3:=CLOSE>V1 AND V20.95*V1;{验证回升,验证已适度创新低}
警2:IF(V3=1,8,0),COLORGRAY;


{价量摆荡法则——马丁.普林格}
BD:=(CLOSE/MA(CLOSE,28)-1)*100;
警3:7.5*(BD<-10),COLORCYAN;

{通达信虚拟成交量周、3日、日、120分钟、60、30、15分钟}
VV1:=IF(CLOSE<150,100*VOL/(FINANCE(7)/100),IF(PERIOD=8,VOL/10000,AMOUNT/100000000));
VV0:=IF(FROMOPEN>120,FROMOPEN-120,FROMOPEN);
VV2:=IF(FROMOPEN<=60,FROMOPEN,IF(FROMOPEN<=120,FROMOPEN-60,IF(FROMOPEN<=180,FROMOPEN-120,IF(FROMOPEN<=240,FROMOPEN-180,FROMOPEN))));
VV3:=IF(FROMOPEN<=30,FROMOPEN,IF(FROMOPEN<=60,FROMOPEN-30,IF(FROMOPEN<=90,FROMOPEN-60,IF(FROMOPEN<=120,FROMOPEN-90,IF(FROMOPEN<=150,FROMOPEN-120,IF(FROMOPEN<=180,FROMOPEN-150,IF(FROMOPEN<=210,FROMOPEN-180,IF(FROMOPEN<=240,FROMOPEN-210,FROMOPEN))))))));
VV4:=IF(FROMOPEN<=15,FROMOPEN,IF(FROMOPEN<=30,FROMOPEN-15,IF(FROMOPEN<=45,FROMOPEN-30,IF(FROMOPEN<=60,FROMOPEN-45,IF(FROMOPEN<=75,FROMOPEN-60,IF(FROMOPEN<=90,FROMOPEN-75,IF(FROMOPEN<=105,FROMOPEN-90,IF(FROMOPEN<=120,FROMOPEN-105,IF(FROMOPEN<=135,FROMOPEN-120,IF(FROMOPEN<=150,FROMOPEN-135,IF(FROMOPEN<=165,FROMOPEN-150,IF(FROMOPEN<=180,FROMOPEN-165,IF(FROMOPEN<=195,FROMOPEN-180,IF(FROMOPEN<=210,FROMOPEN-195,IF(FROMOPEN<=225,FROMOPEN-210,IF(FROMOPEN<=240,FROMOPEN-225,FROMOPEN))))))))))))))));
VV6:=IF(CURRBARSCOUNT=1,IF(PERIOD=5,VV1*240/FROMOPEN,IF(PERIOD=8,VV1*120/VV0,IF(PERIOD=4,VV1*60/VV2,IF(PERIOD=3,VV1*30/VV3,IF(PERIOD=2,VV1*15/VV4,VV1))))),VV1);
VV:=IF(PERIOD=6,IF(WEEKDAY=1,5*VV6,IF(WEEKDAY=2,5*VV1/2,IF(WEEKDAY=3,5*VV1/3,IF(WEEKDAY=4,5*VV1/4,VV1)))),IF(PERIOD<=5 OR PERIOD=8,VV6,VV1)),COLORRED,LINETHICK1;

BDV:=(VV/MA(VV,28)-1)*100;
警4:7.2*(BDV<-50),COLORGREEN;



-------------
参考链接:《顶尖操盘手买入规则&指标源码》
http://www.360doc.com/content/080819/18/2296_1557067.html